Outlook client for CRM 4 with rollup 10

MS Dynamics logo

Finally Microsoft have released a client installation package with a recent rollup already included in the package (“slipstreamed”). Unfortunately, nearly 4 weeks after the release of update rollup 11 it is only rollup 10 that is included. While this is a move forward from the rollup 7 client that was available, it still means that most people are going to need to install the client and then immediately apply a patch to UR11, so it is probably of limited help really. Thanks but no thanks.

Get the new CRM 4.0 client for Outlook with Update Rollup 10 if you are using the on-premise or partner-hosted (“service provider”) versions of CRM. If you are using CRM online you are stuck with installing the original version of the special online client and patching it yourself. Note: CRM on-demand from Microsoft is only available in the US and Canada despite the announcement back in April about worldwide release, because it seems that will only be for the next release, version 5 available later this year.

Hat tip to The CRM Business for the original heads-up on this one.

Usual CRM Update – Rollup 11

Roll-up, roll-up, read all about it. Yes, the usual updates for Dynamics CRM 4 have been released and you can download the components and versions you need from this page. The knowledgebase article kb981328 has the detailed information about Update Rollup 11 for Microsoft Dynamics CRM 4.0, including the prerequisites:

You must have Microsoft Dynamics CRM 4.0 installed to apply this update rollup. Update Rollup 7 is a prerequisite for Microsoft Dynamics CRM for Microsoft Office Outlook and Microsoft Dynamics CRM Data Migration Manager.

Update Rollup 1, Update Rollup 2, Update Rollup 3, Update Rollup 4, Update Rollup 5, Update Rollup 6, Update Rollup 7, Update Rollup 8, Update Rollup 9 and Update Rollup 10 are not prerequisites for the server section of Microsoft Dynamics CRM.

Additionally, you must have Microsoft .NET Framework 3.5 Service Pack 1 installed to apply Update Rollup 11. To obtain Microsoft .NET Framework 3.5, visit the following Microsoft website: Microsoft .NET Framework 3.5 Service Pack 1 (http://www.microsoft.com/downloads/details.aspx?FamilyID=ab99342f-5d1a-413d-8319-81da479ab0d7&DisplayLang=en)

Note that for the server component there is no prerequisite, this rollup can be installed on a base installation (plus MUI if you have multiple languages installed). For the Outlook client you need rollup 7 (same goes for the data migration manager), and for new client installations you can just install the Outlook CRM client with rollup 7 already slipstreamed in. I must admit I find it annoying that the client install is not set up with a proper manifest to trigger UAC elevation – you have to remember to do “run as administrator” (if you are not using the deployment management tools, as many small businesses may not bother to do). The fact that programs prompt me rather than having to remember to do this is one of the reasons I like UAC (since I never run my client machine with local admin rights).
Read about UR11 highlights and the (old) new help files»